MoparFins

Techical Discussions => Tech- - FUEL => Topic started by: Bill on April 08, 2008, 05:31:37 PM

Title: Arghhhh another fuel pump...
Post by: Bill on April 08, 2008, 05:31:37 PM
Well I guess I'm replacing another fuel pump.  This one has been in for roughly three months and has less than a mile on it, but has about 3 hours of idle time.   I thought maybe the tank was dry since the indicator was about an eigth of a tank..  Dropped 3 gallons in tonight and primed her four times and no juice.  Fired up the compressor, then ran some air down the line.  Got fuel back, alot of it.  So I quickly popped the line back on the fuel pump, and I got fuel shooting out of the other side of the pump, connected the filter as quick as I could and got fuel out of that.  By this time the pressure had subsided.  So I proceed to prime and crank one more time.  NADA.  Pull the tank side of the fuel line and it still had fuel there...  I'm beginning to hate mechanical pumps all over again.
Title: Arghhhh another fuel pump...
Post by: Stitcherbob on April 08, 2008, 07:14:10 PM
How is the pump rod? Is it worn? And is there any crap showing up in the filter?
Possiblity of getting an old pump that was on the shelf too long and dried out also.... (440's aren't on the roads as much now, leading to old stock at the parts warehouses)


Title: Arghhhh another fuel pump...
Post by: Bill on April 09, 2008, 03:19:54 AM
Well with out tearing the thing down the rod I would think is ok.  Seemed to move free enough.   Replaced the filter since I thought maybe it was plugged but the old one had flow and nothing bad came out of the inlet.  I mean I could blow through it with no trouble.
 
I will say this though the last time I had it in the driveway idling it acted like it had a dead cylinder so I backed it up and parked her.  Now when I prime the carb she runs smooth as silk.  I was thinking maybe plugged line but that doesn't seem tot be the case so far.
Title: Arghhhh another fuel pump...
Post by: Steve on April 09, 2008, 04:47:08 AM
Bill
 
The ends of the pump rods wear down on big blocks.  I've seen cam lobes wear down on small blocks too.  That's what Bob was asking.  It's hard to tell if the pump rod is worn out or not.
 
There's only a couple of reasons for a pump to do that.  one of them is  a just plane crappy pump.
Title: Arghhhh another fuel pump...
Post by: Bill on April 09, 2008, 11:34:07 AM
Yup crappy pump would be my guess.  What do you expect for foreign made and $15.00?