MoparFins

Techical Discussions => Tech- - Engine => Topic started by: Jay on July 04, 2012, 10:35:22 AM

Title: so its been awhile
Post by: Jay on July 04, 2012, 10:35:22 AM
Hi ppl... its been awhile.. been busy working and finally got time to work on my 66 Chrysler.
 
got some stuff done, anti-sway bar links are fixed and done...
 
(http://img.photobucket.com/albums/v735/wolverine652001/208962_3777538514295_238288231_n.jpg)
 
the start.. took the carb to a guy and hes going to rebuild the carb.
(http://img.photobucket.com/albums/v735/wolverine652001/66engine.jpg)
 
tore down the intake to put in a new intake gasket. it was a headache lining up the bolts and remembering where all stuff goes back on.
(http://img.photobucket.com/albums/v735/wolverine652001/S6300735.jpg)
 
 
looking good for a 107k miles!
(http://img.photobucket.com/albums/v735/wolverine652001/S6300736.jpg)
 
well i ordered gaskets but they came in pieces... its been previously opened so i gotta return them and get a new set.
(http://img.photobucket.com/albums/v735/wolverine652001/S6300737.jpg)
Title: so its been awhile
Post by: Guests on July 04, 2012, 05:24:51 PM
Not too bad looking inside. Couple turns with Pennzoil and she will look brand new inside. Glad you could get the time to work on her.
Title: so its been awhile
Post by: Steve on July 04, 2012, 07:18:14 PM


 
Title: so its been awhile
Post by: Jay on July 05, 2012, 04:02:33 AM
a retired police offier told me i should run some mystery marvel oil in it for about 500 miles before oil change and should clean that gunk out...   has any of you used that stuff? ive used it once on my OLLLLLLD high school car and needless to say, that oil pump gave out about 5k miles later and since then ive never used it again...
 
birdman6520012012-07-05 09:12:15
Title: so its been awhile
Post by: Jay on July 05, 2012, 04:11:07 AM
Heres the picture of the valve cover gasket as it came out of the box like this. someone had purchased this, grabbed it by the end and didnt know they were holding the gasket, and ripped/broke the ends of the gaskets... returned it without the store inspecting it and got their money back... what a joke and then i get the gasket and its in pieces... go figure.. today i go back and get another set or if they have to order it like everything else i had to get for this car.
 
(http://img.photobucket.com/albums/v735/wolverine652001/531376_3824638291760_693703091_n.jpg)
Title: so its been awhile
Post by: Steve on July 05, 2012, 06:44:33 AM


That can be a problem.  That's why I didn's suggest it.  But of it's a low mileage car (I forget) then youhould be OK
Title: so its been awhile
Post by: Jay on July 06, 2012, 04:47:35 AM
Motor mounts done...
 
(http://img.photobucket.com/albums/v735/wolverine652001/IMG-20120705-01598.jpg)
 
(http://img.photobucket.com/albums/v735/wolverine652001/IMG-20120705-01599.jpg)
 
SURE DOES PROP UP THE ENGINE!!!
(http://img.photobucket.com/albums/v735/wolverine652001/IMG-20120705-01600.jpg)
 
YOU CAN SEE IT SLIGHTLY TILED TO THE LEFT, THATS WHY THE NEW MOUNT ON RIGHT AND OLD MOUNT STILL IN LEFT.
(http://img.photobucket.com/albums/v735/wolverine652001/IMG-20120705-01601.jpg)
 
LEFT ENGINE MOUNT LEFT TO GO...  LOOKS LIKE TIGHT SPOT...
(http://img.photobucket.com/albums/v735/wolverine652001/IMG-20120705-01602.jpg)
Title: so its been awhile
Post by: Steve on July 06, 2012, 08:19:50 AM


When it's done, the car will ride/handle like new
Title: so its been awhile
Post by: Jay on July 06, 2012, 08:58:49 AM
i thought about it but i need it ready for sept and its only doing a 40 mile drive from the church to town for a wedding. the groomsmen are riding in my new ford and the girls are riding in my brother's new avalanche so they will be following me. i do have a press and its behind me when i take these pictures.... but i dont know if its the right kind of press. this is just a jack machine press type.... i do wanna do suspension but i am only available on sundays to work on my car.. otherwise im gone all week.

Title: so its been awhile
Post by: Jay on July 06, 2012, 08:59:25 AM
Quote from: POLARACO
That can be a problem.  That's why I didn's suggest it.  But of it's a low mileage car (I forget) then youhould be OK



 
 
 
youre referring to what i mention about marvel mystery oil?
Title: so its been awhile
Post by: Steve on July 06, 2012, 02:03:31 PM

Quote from: birdman652001
Quote from: POLARACO
That can be a problem.  That's why I didn's suggest it.  But of it's a low mileage car (I forget) then youhould be OK



 
 
 
You have a pressure washer?  Would do that engine wonders
Title: so its been awhile
Post by: Jay on July 07, 2012, 07:25:40 AM
i will probaby have a professional do my suspension after the wedding is done. Yes i do have a pressure washer. I just need to get this done and then go get a major wash done. i need to fix the heater on it to use the pressure washe to get the oil/grease off.
Title: so its been awhile
Post by: Steve on July 07, 2012, 08:31:18 AM


Over the years I have learned.  The first thing I do is wash it all down.  I probably have 50 states layin in my back yard.  LOL
Title: so its been awhile
Post by: Jay on July 07, 2012, 05:53:27 PM
yah i do like to wash my engine bay anyways,.... so i will do it after its done worked on bc i know there will be oil and grease from working on it. 
Title: so its been awhile
Post by: Jay on July 21, 2012, 06:21:49 PM



ill search fuel forum after i get off here and see.
birdman6520012012-07-21 23:37:20
Title: so its been awhile
Post by: Jay on July 21, 2012, 06:42:24 PM


is this a good idea? how come it wasnt standard from factory let alone already in a new intake gasket box?
Title: so its been awhile
Post by: Steve on July 21, 2012, 07:37:40 PM


If you want to install one and don't have it, there is a small backless insulation piece of fiberglass sold in home Cheapo.  It's light yellow.  You can get that, and wrap it in HD aluminum foil.  That's all it is.
Title: so its been awhile
Post by: Guests on July 21, 2012, 07:38:56 PM
I like using an aluminum heat sink (a gasket cutout in aluminum, about 5/16ths inch, and cardboard material on either side) which works well for protection against heat between a cast iron intake and the carb base.
Title: so its been awhile
Post by: Jay on July 22, 2012, 07:20:16 AM

Quote from: POLARACO

All now im waiting on is the Carb. also has anyone had insight on what i should do with the fuel guage? i get light flashing when i hook my test light to the power to the sending unit... but no guage reading. grounding?????
Title: so its been awhile
Post by: Jay on September 02, 2012, 07:56:09 PM
got the carb back... no start.. :( so i cranked it with the fuel line open and no fuel coming, so i went back and put air through the tank and got the fuel flow, now when i press the gas pedal, its shooting gas in but no fire, so i have a spark plug tester and its showing sparks, i think i prob flooded it but i hope it starts. the carb looks in good shape and super clean now. once i can get it running, the hood is going back on and the car is done! cant wait to drive it a few more times before i will have to store it for the winter.