MoparFins

Techical Discussions => Tech- - ELECTRICAL => Topic started by: Per Therkildsen on June 01, 2009, 02:28:13 AM

Title: Alternator meter gone wild
Post by: Per Therkildsen on June 01, 2009, 02:28:13 AM
Hello folks.
 
My Alternator meter is gone crazy, if the engine is hot and at idle the meter is on the low side, but when i just give a little gas its going to the top almost bending the stick.
 
I have checked all the connections at the bulkhead and they all look fine.
(http://www.moparfins.com/forum/attachments/223/P6010070.JPG)
(http://www.moparfins.com/forum/attachments/223/P6010071.JPG)
 
But then i have this blank shiny thing i think is my charging relay (correct me if im wrong)
and if you look close at female connctor the 2 holes are a little melted.
(http://www.moparfins.com/forum/attachments/223/P6010072.JPG)
I hope someone can give me a solution too this, i dont want too ruin something so i dont drive until i know whats going on.
Title: Alternator meter gone wild
Post by: Stan Paralikis on June 01, 2009, 03:15:29 AM
It never hurts to put in a new voltage regulator.  They're cheap enough.
Title: Alternator meter gone wild
Post by: Jacques on June 01, 2009, 03:44:36 AM
And replace the connector as well.

Title: Alternator meter gone wild
Post by: Steve on June 01, 2009, 05:24:36 AM
Yes.  Those pig tails are known to go bad and I've seen the pins in the regulator break.  But that's not the problem.
 
Check the connection on the ammeter.  You were just in there, you my have upset a delicate situation.
 
Slap some vasoling on that bulk head connector.  With a load, check the voltage on both sides.  You may have a situation brewing in the bilkhead you can't see.  Check your grounds on the engine and voltage reg.
 
Proud of you son.  You went to the most likely suspect first
Title: Alternator meter gone wild
Post by: Per Therkildsen on June 01, 2009, 10:43:42 AM
I will see if i can find a new pig tail and regulator.
 
And then i will have a look at the back side of the bulk connector, and i know i have to change my regulator on the dash.
 
So maybe i have to go for all of those right away.
 
Title: Alternator meter gone wild
Post by: Steve on June 01, 2009, 11:47:18 AM
Look on the back of the fuse panel as well.  B and C wiring were similar.
 
What you are describing is a bad power connection between the ammeter and the bat/alt.
Title: Alternator meter gone wild
Post by: Per Therkildsen on June 02, 2009, 06:24:22 AM
Is it possible that someone have a link for me were i can get all 3 things.
regulator and pig tail, and regulator for the dash.
 
Or else i have to get from different places.
Title: Alternator meter gone wild
Post by: Per Therkildsen on June 03, 2009, 07:01:25 AM
Have found regulator and piggy tail.
 
Right now im charging 15,6v and i think thats way too much, but could that be the result if the regulator is burned.
Title: Alternator meter gone wild
Post by: Steve on June 03, 2009, 07:04:43 AM
No . . .As said, you have a bad connection somewhere.  Check the voltages at the alternator, both the blue and the primary wire.  Check it inside the car, then outside.
 
Idle, key on only, key off, idle with a load.  You have a bad connection somewhere and I am willing to bet it's at the bulkhead, fuse block or the ammeter
Title: Alternator meter gone wild
Post by: Jacques on June 03, 2009, 07:48:26 AM
Check my topic on my charging issue. Though you will want to go for a permanent solution.