MoparFins

Techical Discussions => General Tech- - BRAKES => Topic started by: Brian on May 05, 2009, 02:57:44 PM

Title: Brakes draggin...
Post by: Brian on May 05, 2009, 02:57:44 PM
Ideas?
Title: Brakes draggin...
Post by: Snotty on May 05, 2009, 03:19:51 PM
Sounds like a booster/MC problem to me Brian.  Just because they are new or remaned does not mean they will be trouble free, unfortunately.  I put a brand-new MC on my Newport before I swaped it for disks.  Not 6 months later I stared having brake problems - the MC went bad.
It was new!! 
I also had a rebuilt booster go out within a year of putting it on - that was on the '62.
 
You might want to check those.
Title: Brakes draggin...
Post by: Steve on May 05, 2009, 04:18:14 PM
Brian
 
Is it one wheel?  Or an axle?
Title: Brakes draggin...
Post by: Steve on May 05, 2009, 04:36:23 PM
Brian
Is it one wheel or an axle.
If it's one wheel, it's probably a bad hose.  If it's the whole rear axle it still could be a hose.
If it's an axle
With the brakes locked in the dragging mode, crack the corrisponding fitting at the master.  If you get a spurt, it's a problem with the master.  If it doesn't, it's either the hose, or you got some crap in the line when you put the valve in.  If it just one wheel, it's most likely a bad hose or crap in that one line.
The pedal won't return if there is not enough force ftom the fluid coming back
 
POLARACO2009-05-05 21:38:41
Title: Brakes draggin...
Post by: Brian on May 05, 2009, 09:06:58 PM
The return of the brake pedal is fine at idle or at lower road speeds, it just seems to have a problem returning when the road speed is up.(http://www.moparnuts.com/forums/images/smilies/huh.gif)
Title: Brakes draggin...
Post by: Steve on May 06, 2009, 03:57:55 AM
OK  I got you now
 
You said "Brake" dragging.
 
Is that a new booster?
 
Yes on the clutch spring
Title: Brakes draggin...
Post by: Robert Rottman on May 17, 2009, 04:25:18 PM
The way you have described this makes me think that its a change in vacuum? The booster has a vacuum line to it right? All my cars are manual or I'd go and look...cracked/collapsed hose? 
Title: Brakes draggin...
Post by: Brian on May 18, 2009, 03:59:57 PM
I'm thinking along those lines now...maybe it's the check valve that came on the reman booster?  I'll change that out and see what happens, since this is the easiest and cheapest thing to start with.(http://www.moparfins.com/forum/smileys/smiley4.gif)
 
Title: Brakes draggin...
Post by: Rich on June 14, 2009, 09:30:54 PM
Here is a piece of advice for everyone doing a brake conversion: try using Valvoline Synthetic Fluid, it doesn't absorb moisture from the air like regular fluid will, and will make your rebuilt MC last much longer.  Most rebuilt MC's are just honed slightly and still have a lot of gunk embedded in the metal, and so after a year or so of absorbing moisture from the air they start rusting internally and leaking.