MoparFins

Members Projects => MEMBERS Project Cars in Progress => Topic started by: Rob Roche on May 23, 2008, 07:39:53 PM

Title: Slow progress.....but progress!
Post by: Rob Roche on May 23, 2008, 07:39:53 PM
Well, almost got the last of my 1/3rd of the tax "rebate" check spent. Today the Fedex truck delivered most of my front suspension bushings. Thanks Rock Auto!

   (http://pic70.picturetrail.com/VOL1789/7783792/18240547/318488211.jpg)

Then the box from Summit showed up...had this inside.

(http://pic70.picturetrail.com/VOL1789/7783792/18240547/318488212.jpg)

17 X 9, 5" backspace Cragar Soft "D". Test fit looks pretty good so far
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/318488527.jpg)
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/318488525.jpg)

After the front end gets rebuilt I'll try it again with a tire (after measuring only once 275/45-17 should fit fine 10" wide on a 9" rim....it'll be close on the tierod end. ) I'm thinking a set of Gumball sticky Falken RT-615's should keep this tank glued down fairly well. They're only 25.6" tall...the 255/60-15's I have are 27". She'll sit kinda low I think.

Good thing the 383 is coming out soon....
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/318488530.jpg)
Note to self...check the freeze plugs in the 413 BEFORE installing it! (http://www.moparfins.com/forum/smileys/smiley36.gif)



Title: Slow progress.....but progress!
Post by: Brian on May 23, 2008, 08:20:34 PM
Right on...good to see the wagon making a come back!!!(http://www.moparfins.com/forum/smileys/smiley20.gif)
 
Wow...that there is one ugly frost plug...or hole...not much left of that frost plug eh!
 
 
Title: Slow progress.....but progress!
Post by: Rob Roche on May 23, 2008, 08:23:59 PM

I'm actually working on the '64 300 right now....the poor 'ol Wagon is a parts storage bin at the moment. "Waldo the Wagon" will get some love eventually. The '64 is closer to being on the road and in much better shape.

Here's the 300 just before the "intake swap and drive to Spring Fling" thrash..
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/309033614.jpg)

Things got uglier as I started wrenching on it.
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/310078978.jpg)

I didn't make it to Spring Fling in it....(http://www.moparfins.com/forum/smileys/smiley11.gif)
66gg1tnc2008-05-24 01:27:27
Title: Slow progress.....but progress!
Post by: Rob Roche on May 26, 2008, 12:59:45 PM
Minor progress today. Finally got the right side exhaust manifold off. Test fit the Hedman Shorty's....they fit fine but the collector is right on top of the torsion bar (http://www.moparfins.com/forum/smileys/smiley5.gif) Oh well....I know they'll fit the wagon so reboxed and stuffed in the '66 T&C for when that project lifts off.

This week's goals. Remove the left exh manifold, rusty exh pipes and (fingers crossed) yank the 383 out.
Title: Slow progress.....but progress!
Post by: Bill on May 28, 2008, 07:25:47 PM
Do those Hedmans bolt up to the stock exhaust or is it requiring a new exhaust all the way out?
Title: Slow progress.....but progress!
Post by: Rob Roche on May 28, 2008, 07:34:21 PM
New exhaust...they're NOT a direct replacment size/fit wise for stock logs. As for my '64.....Sanderson block huggers are about the only thing that'll fit. '65 up C's you got Hedman Shorty's, TTI and a few others I think. TTI makes a whole bolt in system for C's, even wagons.
Title: Slow progress.....but progress!
Post by: Rob Roche on May 30, 2008, 10:50:33 AM
Todays progress was removing the hood, starter and trans dust shield. Then life and family intruded ....so that was it.
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/319401122.jpg)





Title: Slow progress.....but progress!
Post by: Steve on May 30, 2008, 12:15:09 PM
[/QUOTE]
 
I hope those are not Moog lower control arm bushings. . .
 
http://www.moparfins.com/forum/forum_posts.asp?TID=1195 (http://www.moparfins.com/forum/forum_posts.asp?TID=1195)
Title: Slow progress.....but progress!
Post by: Rob Roche on May 30, 2008, 12:19:54 PM
Moog Lower ball joints....Moog uppers came from Summit Racing. All 4 boxes say "made in USA" Moog was the ONLY source for uppers and lowers for my '64. Everything else is Spicer.




Title: Slow progress.....but progress!
Post by: bob gonzalski on May 30, 2008, 04:11:40 PM
howdy I am new to this forum so i'm not sure if i'm doing this right years ago I parted out a 64 300 I kept 413, tranny ,and side chrome and wheel well moldings. I installed the motor and tranny in my 65 coronet .  But I still have the trim do you need any side trim ?
Title: Slow progress.....but progress!
Post by: Rob Roche on May 30, 2008, 06:49:08 PM
Hi 62Dodge!
My side trim is mostly okay...a few dings here and there. A spare set is always a handy thing to have though! Yours a two or four door? Mines a two. PM me and maybe we can work something out....(http://www.moparfins.com/forum/smileys/smiley4.gif)





Title: Slow progress.....but progress!
Post by: bob gonzalski on May 31, 2008, 08:20:39 PM
howdy    Sorry it took so long had to rescue my son his 73 chargers tranny went south. The car was A non letter 2door hard top, the trim is if I remember correctly full body with a silver insert,  I would have to pull it down from the rafters in my shop to verify.  If this is something that you could use let me know, as I am into 1957/58 and 1962 chrysler 300s     thank you  bob
Title: Slow progress.....but progress!
Post by: Mike on June 01, 2008, 12:52:28 PM
Rob is that a picture of a busted Tie rod in the first begining pictures?  Thing looks weird(http://www.moparfins.com/forum/smileys/smiley5.gif)

Title: Slow progress.....but progress!
Post by: Rob Roche on June 01, 2008, 01:35:11 PM
This one?
(http://pic70.picturetrail.com/VOL1789/7783792/18240547/318488525.jpg)
It does look pretty funky. The boot is toast, and ancient grease splattered everywhere. It steered fine and there weren't any clunks or wobblies. I'm gonna change them out anyway (as soon as I can find some)
Title: Slow progress.....but progress!
Post by: Mike on June 01, 2008, 02:45:40 PM
I thought they were tie rods!, they should be easy enough to find, good luck on your quest.

Title: Slow progress.....but progress!
Post by: Rob Roche on June 01, 2008, 03:00:16 PM
Easy to find if it was a '65-up......'64 a different story so far (http://www.moparfins.com/forum/smileys/smiley5.gif)