MoparFins

Please login or register.

Login with username, password and session length
Advanced search  

News:

We changed servers, which is good, and lost all passwords, which is bad. See above.

Pages: [1]   Go Down

Author Topic: Went for a drive.  (Read 732 times)

Snotty

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 3972
    • View Profile
Went for a drive.
« on: May 01, 2014, 08:13:19 AM »

Had a great drive yesterday in my '70 Newport!  I had been having problems with a leak in my gas tank for over two years so I had not filled the car since then.  I put a new tank in (from Rockauto, made in Canada - was perfect!) so I decided to take the old car on a drive - after all, I'm on vacation!  I live in Chico, Ca, on Hwy. 99 some 90 miles north of Sacramento.  It is at the Sierra Nevada Foothills so there are many good routes to take of you want a great day trip.  Here was the route I took if you're interested in looking at a map:




Sorry, no pictures.
Logged
It's green here in Chico!!

300rag

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 687
    • View Profile
Went for a drive.
« Reply #1 on: May 01, 2014, 05:37:36 PM »

You know the rules. Pictures, or it didn't happen. Glad you had a good run though.

Logged
1965 Chrysler 300 convertible 413/ 4 speed ; 1969 Monaco 3-seat wagon 383/727 ; 1969 Monaco 500 2-door 318/727

Snotty

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 3972
    • View Profile
Went for a drive.
« Reply #2 on: May 06, 2014, 09:14:14 AM »

Ha!!  It happened as I have the receipts for the $160 of gas I used!

Logged
It's green here in Chico!!
Pages: [1]   Go Up
 

© 2008-2014 Steve Hobby • © 2015 Allpar, LLC