MoparFins

Please login or register.

Login with username, password and session length
Advanced search  

News:

We changed servers, which is good, and lost all passwords, which is bad. See above.

Pages: [1]   Go Down

Author Topic: Transmission problem  (Read 1247 times)

Daniel Garrido

  • Newbie
  • *
  • Karma: +0/-0
  • Posts: 7
    • View Profile
Transmission problem
« on: July 11, 2012, 03:12:01 PM »

I have a Desoto 1947 Fluid Drive. If it works,  I would stop the car while I am driving, but when I remove the foot from the accelerator and apply the brakes, I feel that the engine is going to stop (like when I apply brakes with the shift engaged in a manual gearshift). Somebody can help me?, Thank you eldany19292012-07-11 20:12:52
Logged

Steve

  • Administrator
  • Hero Member
  • *****
  • Karma: +1/-0
  • Posts: 8653
    • View Profile
Transmission problem
« Reply #1 on: July 11, 2012, 04:45:12 PM »



I'll be asking a 100 questions.  We'll figure it out?
Logged
Favorite Expression. . . Damned Kids.  Lots of projects.  Donations accepted

Daniel Garrido

  • Newbie
  • *
  • Karma: +0/-0
  • Posts: 7
    • View Profile
Transmission problem
« Reply #2 on: July 16, 2012, 05:20:53 AM »


Dear POLARACO

Thank you
for helping me.

 I have been
reading your post since several months ago. I have downloaded your pictures.
They are very useful in my restoration. You are doing a great work!

I always go
to your post when I am looking for information.

The story
of my car (Desoto Custom 1947) starts two years ago.

I saw it on
a classic cars web page at an extremely convenient price.

When I saw
the car, I couldn’t believe how cheap it was. It had been fully restored, but it
seemed it had been abandoned several years ago.

There were strange
details: All the system from the accelerator to the carburetor was missing. The
gas tank was disconnected too and the wiring was cut. Now I think that the objective
was that buyers didn’t ride the car.

The engine had
been restored and it looked wonderful, and I bought the car.

I have
others classic cars, and enjoy to restored them myself. At that moment I was
painting a Model A Victoria 31, and didn’t have time to repair the Desoto. It
was the reason why I was looking for a mechanic to repair it. Nobody answered
my call. At that moment I discovered that nobody wanted to take this job.

I left the Victoria, and started
working on the Desoto.

First, I
connected the gas tank; I did the fuel system, and made the brakes.

Then I
stated to learn about transmission. The Imperial Club web page was a miracle! I
could download all the Service Reference Books. In these books there is a very
didactical explanation about this issue.

I was
lucky, because all the critical parts worked fine: solenoid, anti stall switch,
interrupter switch, kick down switch, except the governor. I bought one through
eBay.

I didn’t
have the transmission relay. I did a circuit with an industrial relay (I am attaching
it, and I want your opinion)

I checked
the circuit, and the last Saturday, I drove the car to test it.

I stopped
the car while I was driving, and it works: the car doesn’t stop the engine, but
I need to press the brakes all the time. If I take out the foot from the
brakes, the car start to move slowly.

I have
other questions: I needed to refill the fluid drive fluid (I put 5 liters). I put 10w oil
(I read a lot of posts about this issue with the difference between TDH tractor
fluid and SAE 10w oil).

I drove the
car for 15 minutes, and then I saw that there was an oil leak and it came from
the transmission zone. I took out the cover plate again, and could see that the
fill plug was wet. I tightened the plug (and besides I put Teflon). I drove the
car for 30 minutes to check it. In this opportunity the oil leak was smaller
than the first time (I refilled ¼ liter). The question is: May the plug be the
reason for the oil leak or may it be any other?uploads/623/14julio2012.jpg  uploads/623/relay1.JPG   uploads/623/relay2.JPG



eldany19292012-07-16 10:26:00
Logged
Pages: [1]   Go Up
 

© 2008-2014 Steve Hobby • © 2015 Allpar, LLC