MoparFins

Please login or register.

Login with username, password and session length
Advanced search  

News:

We changed servers, which is good, and lost all passwords, which is bad. See above.

Pages: [1]   Go Down

Author Topic: Rearend problems...part II  (Read 400 times)

Brian

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 2810
    • View Profile
Rearend problems...part II
« on: August 01, 2009, 02:06:07 PM »

Thanks again guys.
Logged
Brian

02 Chrysler Concorde Lxi
84 Dodge Crewcab, Cummins/5speed
68 Chrysler Station Wagon 440/auto
48 Desoto 2dr Sedan flat 6/3spd manual

Steve

  • Administrator
  • Hero Member
  • *****
  • Karma: +1/-0
  • Posts: 8653
    • View Profile
Rearend problems...part II
« Reply #1 on: August 01, 2009, 02:56:27 PM »

You're not dragging a brake are you?
Logged
Favorite Expression. . . Damned Kids.  Lots of projects.  Donations accepted

Brian

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 2810
    • View Profile
Rearend problems...part II
« Reply #2 on: August 01, 2009, 04:21:29 PM »

Well due to the excessive temps from before the drums are more then likely warpped.  I reset the rear drums and shoes before I left to make sure there was no dragging. 


 
I think I'll get a set of new drums and shoes adn go from there.
 
I also want to get a new solid drive shaft made up, since the orignal is the two piece unit with the rubber filled tail section....who knows what condition that rubber is in after 40+ years and that could be the cause of premature U-joint failure as well.
 
 

Logged
Brian

02 Chrysler Concorde Lxi
84 Dodge Crewcab, Cummins/5speed
68 Chrysler Station Wagon 440/auto
48 Desoto 2dr Sedan flat 6/3spd manual

Pages: [1]   Go Up
 

© 2008-2014 Steve Hobby • © 2015 Allpar, LLC