MoparFins

Please login or register.

Login with username, password and session length
Advanced search  

News:

We changed servers, which is good, and lost all passwords, which is bad. See above.

Pages: [1]   Go Down

Author Topic: Update on my oil pressure problem  (Read 404 times)

Alan

  • Full Member
  • ***
  • Karma: +0/-0
  • Posts: 123
    • View Profile
Update on my oil pressure problem
« on: April 12, 2009, 07:51:22 AM »

My new pump won't be delivered until tomorrow so being restless and wanting to know what was causing my low pressure,  I took my old pump apart and checked it out for wear. It looked ok so I pulled the new pump and put the old one back in, changed the oil and filter and started it up. The pressure was 40 lbs at cold idle, so I drove around for a while to warm it up. I ended up with 20 lbs at idle and 35 lbs when I'm driving and thats with a 42 year old pump. That verifies that the problem was the pump. The rebuilder said to send him the bill for the new pump and he'll reimburse me for it.  The new HV pump should give me even better pressure.
 
I have to say, I'm glad I don't have a GM car. Changing the oil pump would mean dropping the pan.  Changing a Mopar is a breeze.
Logged
Al

Steve

  • Administrator
  • Hero Member
  • *****
  • Karma: +1/-0
  • Posts: 8653
    • View Profile
Update on my oil pressure problem
« Reply #1 on: April 12, 2009, 08:30:27 AM »

I can't believe he didn't put a new pump on a new engine.  Anywhere else that's SOP
 
POLARACO2009-04-12 13:31:02
Logged
Favorite Expression. . . Damned Kids.  Lots of projects.  Donations accepted

Alan

  • Full Member
  • ***
  • Karma: +0/-0
  • Posts: 123
    • View Profile
Update on my oil pressure problem
« Reply #2 on: April 12, 2009, 10:03:28 AM »

It came with a new pump but it turned out to be defective. I put the old one back on to see if I still had low pressure. The pressure was good so I knew that that the new pump was bad. 
Logged
Al

Corey

  • Full Member
  • ***
  • Karma: +0/-0
  • Posts: 246
    • View Profile
Update on my oil pressure problem
« Reply #3 on: April 12, 2009, 01:38:44 PM »

440source.com has a melling high flow oil pump I put one on my fury need something for a mopar big block try them.
 
Steve you might talk to them about being a vender member.
Logged


Your Combobulator has become Discombobulated

Brian

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 2810
    • View Profile
Update on my oil pressure problem
« Reply #4 on: April 12, 2009, 08:57:43 PM »

Quote from: 67Newport
 
Well a big block mopar that is...small blocks are mounted to the rear main in the oil pan....
Logged
Brian

02 Chrysler Concorde Lxi
84 Dodge Crewcab, Cummins/5speed
68 Chrysler Station Wagon 440/auto
48 Desoto 2dr Sedan flat 6/3spd manual

Pages: [1]   Go Up
 

© 2008-2014 Steve Hobby • © 2015 Allpar, LLC