MoparFins

Please login or register.

Login with username, password and session length
Advanced search  

News:

We changed servers, which is good, and lost all passwords, which is bad. See above.

Pages: [1]   Go Down

Author Topic: MSD  (Read 564 times)

Jacques

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 941
    • View Profile
MSD
« on: September 07, 2008, 08:29:04 AM »

I was wondering why my car was driving like crap today.....


My rotor & cap after some 8 or 9000 miles:






Logged
ex-Mopars 1967 Chrysler Newport Custom Coupe, 1973 Imperial LeBaron 2dr hardtop, 1973 Imperial LeBaron 4dr Hardtop, 1971 Plymouth Sport Fury 2 door hardtop

Snotty

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 3972
    • View Profile
MSD
« Reply #1 on: September 08, 2008, 10:07:05 AM »

That looks like normal wear - for 20,000 miles!  I would not expect an eletronic ignition to wear that fast so quickly.
Logged
It's green here in Chico!!

Jacques

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 941
    • View Profile
MSD
« Reply #2 on: September 08, 2008, 10:11:35 AM »

Well, its not exactly a stock ignition that I have  And I gapped the plugs at over .05" which is severe with propane as a fuel, so a weak part in the ignition will show up very quickly.

It was funny because yesterday the car really ran like crap and I feared for the brand new tranny. But back at the shop, I had a good laugh when I discovered this


Logged
ex-Mopars 1967 Chrysler Newport Custom Coupe, 1973 Imperial LeBaron 2dr hardtop, 1973 Imperial LeBaron 4dr Hardtop, 1971 Plymouth Sport Fury 2 door hardtop

James Brown Jr,

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 1140
    • View Profile
MSD
« Reply #3 on: September 08, 2008, 11:53:50 AM »

glad it was something small.
Logged
176K miles 10/22

Jacques

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 941
    • View Profile
MSD
« Reply #4 on: September 08, 2008, 12:16:44 PM »

Yah me too! because I hit the car quite hard on thursday (over 125mph) and on saturday a lot of runs at the track, so much that I smelled the brakes in the car 

Logged
ex-Mopars 1967 Chrysler Newport Custom Coupe, 1973 Imperial LeBaron 2dr hardtop, 1973 Imperial LeBaron 4dr Hardtop, 1971 Plymouth Sport Fury 2 door hardtop

Steve

  • Administrator
  • Hero Member
  • *****
  • Karma: +1/-0
  • Posts: 8653
    • View Profile
MSD
« Reply #5 on: September 12, 2008, 01:42:32 PM »

Huh
They don't look that bad to me. . . Seen allot worse
Logged
Favorite Expression. . . Damned Kids.  Lots of projects.  Donations accepted

Jacques

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 941
    • View Profile
MSD
« Reply #6 on: September 12, 2008, 01:58:27 PM »

Me too, but propane is a little more sensitive to ignition wear than regular gas, and my driving style and the quite hgeave ignition dont help either. What you cant see on the pic is that one edge of the rotor is almost melted away   but usually, I have this kind of wear only after some 30.000 miles and not less than 10k

Tomorrow I'm going to play with the car again, bought a new cap&rotor yesterday.


Logged
ex-Mopars 1967 Chrysler Newport Custom Coupe, 1973 Imperial LeBaron 2dr hardtop, 1973 Imperial LeBaron 4dr Hardtop, 1971 Plymouth Sport Fury 2 door hardtop

Jacques

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 941
    • View Profile
MSD
« Reply #7 on: September 13, 2008, 06:17:14 PM »

Actually, the cap is much worse than the pics show, lot of molten metal 

Guess that I cant complaint about a spark not hot enough


Logged
ex-Mopars 1967 Chrysler Newport Custom Coupe, 1973 Imperial LeBaron 2dr hardtop, 1973 Imperial LeBaron 4dr Hardtop, 1971 Plymouth Sport Fury 2 door hardtop
Pages: [1]   Go Up
 

© 2008-2014 Steve Hobby • © 2015 Allpar, LLC