MoparFins

Please login or register.

Login with username, password and session length
Advanced search  

News:

We changed servers, which is good, and lost all passwords, which is bad. See above.

Pages: [1]   Go Down

Author Topic: What I've been doing  (Read 219 times)

Jason Goldsack

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 990
    • View Profile
What I've been doing
« on: June 17, 2008, 07:48:49 AM »

I haven't had much time to run ole Blue around Southern Ontario as I have been busy with this lawnmower racing deal...

So to let you boys know I'm still around I thought I would post a video showing my tractor in qualifying last weekend...

I hope everyone is well.. and now that the tractor is done I can spend more time with the old Chrysler cruising the highway... I have put maybe 500 miles on it all year... certainly not enough for my liking....

Here's the video..





Logged
Jason

(Eileen)1965 Chrysler Windsor, 361/727/2.76 16.49 @ 86 mph

Jason Goldsack

  • Hero Member
  • *****
  • Karma: +0/-0
  • Posts: 990
    • View Profile
What I've been doing
« Reply #1 on: June 17, 2008, 07:52:07 AM »

Here's the mowchine just after I finished the new header and exhaust



And here is a pic of the tractor...







Logged
Jason

(Eileen)1965 Chrysler Windsor, 361/727/2.76 16.49 @ 86 mph

Bill Mounteer

  • Sr. Member
  • ****
  • Karma: +0/-0
  • Posts: 340
    • View Profile
What I've been doing
« Reply #2 on: June 17, 2008, 09:38:35 AM »

Great job, that is too nice! 

Logged
Some days you eat bear, some days the bear eats you!
Pages: [1]   Go Up
 

© 2008-2014 Steve Hobby • © 2015 Allpar, LLC